A question of permissions?

Having difficulties with AvCanada Forums, the internet etc.. ask your questions here.

Moderators: North Shore, ahramin, sky's the limit, sepia, Sulako

Post Reply
Rank 6
Rank 6
Posts: 473
Joined: Thu Apr 06, 2006 6:48 am
Location: Where the job is!

A question of permissions?

Post by Carrier »

Mrs. C has a MacBook Air running OSX 10.9.5 Mavericks since new in January 2014. After being unwrapped it was set up for one user named USER, who of course was an administrator. Sophos antivirus was installed. Backups have been made by clicking on the Macintosh HD icon, opening the Users folder and then dragging the icon for USER to the desktop image of a portable hard drive. All worked fine until mid-2016. Then two things changed.

Up until then asking Sophos to Scan this Mac resulted in all 745,000 odd files being scanned. After this such scans always stop when there are still about 152,000 files to be scanned. Sophos support is unable to pinpoint the cause but suggests it might have something to do with permissions or exclusions.

Up until this point dragging the USER icon to the portable hard drive image resulted in the computer counting up the number of files to be copied and then making a copy of USER on the portable hard drive. After this point dragging the icon USER results in the MBA counting up the number of files to be copied and then a window opens with the advice:
You may have to enter the name and password for an administrator on this computer to change the item named “USER”
(USER is an administrator and is the only user on the MBA, but still is being asked to enter the name and password for an administrator. As far as I know USER is not being changed but is simply being copied to the portable hard drive.)

Clicking on Continue then opens another window with:
Finder wants to make changes. Type your password to allow this.

The name USER is already in place in this second window, so entering the password and clicking OK results in the folder USER being copied to the portable hard drive.

Clearly the only user on this MBA, who is an Administrator, does not now have the same access as before. Something has changed. I believe I am the unwitting culprit for this.

At about the time of these changes I read a security article that one should not access the Internet using an administrator account. I created a second user account named TWO on the MBA. It was created as a Standard account. It did not have access to the same applications, folders and documents that USER had. To try and solve this I changed TWO to become an administrator. I then changed USER from administrator to a standard account. These changes were of no help.

I decided to reverse the changes so made USER an administrator again and then deleted TWO. USER then reverted to being the only account on the MBA. It was some time later that I realised that my user account changes were probably the reason for the MBA’s behaviour changes and that something had not been corrected.

I now have two items I will appreciate some help with:

First, what changes and where do I need to make them to restore USER to the full administrator access that it had when the MBA was new?

Second, after the first is solved, how do I create a second (standard) account for Internet access that has access to all the applications, folders and documents that USER has?
---------- ADS -----------

Rank 8
Rank 8
Posts: 942
Joined: Thu Jul 03, 2014 4:33 pm

Re: A question of permissions?

Post by 7ECA »

So..., why aren't you just using Time Machine to make backups? It's been around since OS 10.5 Snow Leopard.

Not to mention the fact that Mavericks is four OS' out of date - the current standard is 10.13.1 High Sierra.

I have no idea what you've done to your computer, other than the fact that it is asking you to enter the admin password each time you modify the system level files (User, etc), which is normal.

If you are still annoyed with the behaviour, either update to the latest OS (which you are more than able to do on a 2014 Air), or boot up in recovery mode (cmd - R) and wipe the HD and start fresh.
---------- ADS -----------

Post Reply

Return to “Internet and Computer Help”